【ZOJ3956】Course Selection System(01背包+思维)

题目链接

Course Selection System


Time Limit: 1 Second      Memory Limit: 65536 KB


There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

【题意】

Edward从n门课中选m门,没门课有相应的绩点c,并且Edward可以从中获取相应的快乐值h,输出一个使题中等式最大的答案。

【解题思路】

令a=sigma(hi),b=sigma(ci),那么上式可以化简为f=a^2-ab-b^2=a(a-b)-b^2。

那么当b一定时,a越大f越大,那么就变成01背包问题啦。

【代码】

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
LL h[505],c[505],f[500*100+5];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,C=0;
        memset(f,0,sizeof(f));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&h[i],&c[i]);
            C+=c[i];
        }
        for(int i=0;i<n;i++)
            for(int j=C;j>=c[i];j--)
                f[j]=max(f[j],f[j-c[i]]+h[i]);
        LL ans=0;
        for(int i=0;i<=C;i++)
            ans=max(ans,f[i]*f[i]-f[i]*i-i*i);
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/83062294
今日推荐