[洛谷]P1596 [USACO10OCT]湖计数Lake Counting (#搜索 -1.9)

题目描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个NxM(1<=N<=100;1<=M<=100)网格图表示。每个网格中有水('W') 或是旱地('.')。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

第1行:两个空格隔开的整数:N 和 M 第2行到第N+1行:每行M个字符,每个字符是'W'或'.',它们表示网格图中的一排。字符之间没有空格。

输出格式:

Line 1: The number of ponds in Farmer John's field.

一行:水坑的数量

输入输出样例

输入样例#1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

输出样例#1

3

思路

水题,就是连通块的纯模版,下面用dfs做。

#include <stdio.h>
#include <iostream>
using namespace std;
int n,m,s;
char a[101][101];
int tox[9]={0,1,0,-1,0,1,1,-1,-1};
int toy[9]={0,0,1,0,-1,-1,1,1,-1};
inline void dfs(int x,int y)
{
	register int i;
	a[x][y]='.';
	for(i=1;i<=8;i++)
	{
		int x1=x+tox[i];
		int y1=y+toy[i];
		if(x1>=1 && x1<=n && y1>=1 && y1<=m && a[x1][y1]=='W')
		{
			dfs(x1,y1);
		}
	}
	return;
}
int main()
{
	ios::sync_with_stdio(false);
	int i,j;
	cin>>n>>m;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{
			cin>>a[i][j];
		} 
	}
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{
			if(a[i][j]=='W')
			{
				s++;
				dfs(i,j);
			}
		}
	}
	cout<<s<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Apro1066/article/details/81843589