POJ 1200 Crazy Search——————Hash算法

Language:Default
Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32963 Accepted: 9050

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source


哈希算法,不过这需要用一个 字符—>数字 的映射

然后滚动的寻找每个子串对应的hash值,再判断这个hash值是否存在就好了
比如第一个样例
先寻找 daa 的hash值
然后再找 aab ,aba,bab,aba,bac, 的hash值
如果对应的hash值没有出现过,就ans++


code:

//#include<bits/stdc++.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const int base = 233;
const int MAXN=16000007;
char str[MAXN];
int h[MAXN];
int id[300],idx=1;


int main()
{
    int n,m;
    scanf("%d %d %s",&n,&m,str);
    int len=strlen(str);
    memset(id,0,sizeof(id));

    for(int i=0;i<len;i++)
        if(id[str[i]]==0)
            id[str[i]]=idx++;// 字母-->数字的  映射, 没有的话会Runtime Error

    ull hb=1;
    for(int i=0;i<n;i++)    hb*=m;

    ull sh=0;
    for(int i=0;i<n;i++)    sh=sh*m+id[str[i]];

    int ans=0;
    for(int i=0;i+n<=len;i++)
    {
        if(h[sh]==0){h[sh]=1;ans++; }
        sh=sh*m-id[str[i]]*hb+id[str[i+n]];
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81806280