poj1200(字符串Hash)

Crazy Search
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30686   Accepted: 8503

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

#include<iostream>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<list>
#include<set>
#include<iomanip>
#include<cstring>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<cassert>
#include<sstream>
#include<algorithm>
using namespace std;
const int MAXN = 2e7;
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
typedef long long ll;

bool hash[MAXN];
char w[MAXN];
int id[500]; //字符最多为256

int main()
{
	int nc,n,i,j;
	while(~scanf("%d%d",&n,&nc))
	{
		memset(hash,0,sizeof(hash));
		memset(id,-1,sizeof(id));
		int cnt=0;
		scanf("%s",w);
		int len=strlen(w);
		for(i=0; i<len&&cnt<nc; i++)//nc种字符转化为0,2,...,nc-1
		{
			if(id[w[i]]!=-1) continue;
			id[w[i]]=cnt++;
		}
		int ans=0;
		for(i=0; i<len-n+1; i++)//枚举长度为n的子串
		{
			int s=0;
			for(j=i; j<i+n; j++)
			{
				s=s*nc+id[w[j]];//转化为相应的nc进制
			}
			if(hash[s]) continue;//如果已存在,到下一个字串
			ans++;//如果之前未存在,ans++
			hash[s]=true;
		}
		printf("%d\n",ans);
	}
	return 0;
}














猜你喜欢

转载自blog.csdn.net/kyrie_10/article/details/79211840