poj 1200 Crazy Search(字符串HASH)

Current Contest
Past Contests
Scheduled Contests
Award Contest
User ID:
Password:
Register
Language:
Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32983 Accepted: 9054

Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint
Huge input,scanf is recommended.
先给每个字母分配一个 H A S H 值,然后记录前缀,查找满足条件的即可。

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
const int  maxn = 1e7+20;
const int  mod=1e6+7;
char s[maxn];
int  hashs[maxn];
bool  re[maxn];
int main()
{
    unsigned  n,m;
    scanf("%d %d %s",&n,&m,s);
    int l=strlen(s);
    int k=1;
    for(int i=0;i<l;i++)
    {
        if(!hashs[s[i]-'a'+1])
        {
            hashs[s[i]-'a'+1]=k++;
        }
        if(k==m) break;
    }
    int ans=0;
    for(int i=0;i<=l-n;i++)
    {
        unsigned long long  sum=0;
        for(int j=0;j<n;j++)
        {
            sum=(sum*m+hashs[s[i+j]-'a'+1]);
        }
        if(!re[sum])
        {
            re[sum]=1;
            ans++;
        }
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/81835033