poj 2689 Prime Distance (大区间素数)

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

Waterloo local 1998.10.17

题意,求一个区间内的相隔最近和最远的相邻素数

思路: 这个题首先筛素数,范围巨大,直接筛肯定不行,我们可以先把1至50000内的素数筛出来,再利用筛出的数去对应区间内的数,这里数组开不到那么大,就加个偏移量好了,素数筛好后,枚举就好。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
#define maxn 50005
#define maxm 1000005
ll cnt;
ll p[maxn];
ll vis[maxn];
ll f[maxm];
void init()
{
    cnt=0;
    vis[0]=1;
    vis[1]=1;
    memset(p,0,sizeof(p));
    memset(vis,0,sizeof(vis));
    for(ll i=2;i<maxn;i++)
    {
        if(!vis[i])
        {
            p[cnt++]=i;
            for(ll j=i*i;j<maxn;j+=i)
            vis[j]=1;
        }
    }
}
int main()
{
    ll l,u;
    init();

    while(~scanf("%lld%lld",&l,&u))
    {
        if(l==1)
        l=2;
        ll i,j,a,b;
        memset(f,0,sizeof(f));
        for(i=0;i<cnt;i++)
        {
            a=(l-1)/p[i]+1;
            b=u/p[i];
            for(j=a;j<=b;j++)
            {if(j>1)
            f[j*p[i]-l]=1;}
        }
        ll maxl=-1,minl=0x3f3f3f3f,p=-1;
        ll x1,x2,y1,y2;
        for(i=0;i<=u-l;i++)
        {
            if(f[i]==0)
            {

            if(p==-1)
             {
                p=i;
                continue;
             }
             if(i-p>maxl)
             {
                 maxl=i-p;
                 x1=l+p;
                 y1=i+l;
             }
             if(i-p<minl)
             {
                 minl=i-p;
                 x2=l+p;
                 y2=i+l;
             }
         p=i;
            }
        }
        if(maxl==-1)
        {
            printf("There are no adjacent primes.\n");

        }
        else
        printf("%lld,%lld are closest, %lld,%lld are most distant.\n",x2,y2,x1,y1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81710742
今日推荐