Crossing River (贪心)

 Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

题目大意:有n个人要过河,只有一条船,每次最多坐两个人,每次需要一个人把船开回来,过剩下的人,给出每个人单独过河的时间,两个人过河时,所花的时间为两个人中长的那个,求所有人过河需要的最短时间

思路:先把时间从小到大排序,为了使时间尽量短,把耗时最长的两个人带到对岸耗时的情况分为两种:(a0,a1 为耗时最短的两个)

1. (ak+a0)+(a[k-1]+a0)  : (ak和a0先过河,a0回来,a[k-1]和a0过河,a0回来)——a[k]+a[k-1]+2*a[0];

2.(a1+a0)+(ak+a1)   :  (a1和a0先过河,a0回来,a[k]和a[k-1]过河,a1回来)——a[k]+a[0]+2*a[1];

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int k=n-1,sum=0;
        while(k>=3)
        {
            if(a[k]+a[k-1]+a[0]*2<a[k]+a[0]+2*a[1])
                sum+=a[k]+a[k-1]+a[0]*2;
            else
                sum+=a[k]+a[0]+2*a[1];
            k-=2;
        }
        if(k==2)
          sum=a[2]+a[1]+a[0]+sum;
        if(k==1)
            sum+=a[1];
        if(k==0)
            sum+=a[0];
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81773124