nyoj716 - River Crossing - 动态规划

River Crossing

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation.

 

Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes it traverse the river more slowly.

 

When Afandi is on the raft alone, it can cross the river in M minutes When the i sheep are added, it takes Mi minutes longer to cross the river than with i-1 sheep (i.e., total M+M1   minutes with one sheep, M+M1+M2 with two, etc.).

 

Determine the minimum time it takes for Afandi to get all of the sheep across the river (including time returning to get more sheep).

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 5 Each case contains:

* Line 1: one space-separated integers: N and M (1 ≤ N ≤ 1000 , 1≤ M ≤ 500).

* Lines 2..N+1: Line i+1 contains a single integer: Mi (1 ≤ Mi ≤ 1000)
输出
For each test case, output a line with the minimum time it takes for Afandi to get all of the sheep across the river.
样例输入
2    2 10   355 10  3461001
样例输出
1850
来源
第六届河南省程序设计大赛
上传者
ACM_赵铭浩

分析:

动态规划,dp[i]表示把i个送过去需要的时间(而不是一次送i个的时间,可以送许多次,只要dp[i]表示的是最小的结果就可以啦)

从小到大,递推出来

for(int i=1;i<=n;i++){
    dp[i]=a[i]+m;
    for(int j=1;j<i;j++){
        dp[i]=min(dp[i],dp[j]+m+dp[i-j]);//一下子把i个全送出去,或者 把j个送出去+把i-j个送出去
    }
}

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>

using namespace std;
int a[1003],dp[1003];
int main(){
    int t,n,m,x;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));

        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            a[i]=x+a[i-1];
        }
        for(int i=1;i<=n;i++){
            dp[i]=a[i]+m;
            for(int j=1;j<i;j++){
                dp[i]=min(dp[i],dp[j]+m+dp[i-j]);
            }
        }
        printf("%d\n",dp[n]);
    }
}


猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/80385249