HDU1260 Tickets dp

 Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

思路:

今天有点累,不想多说了,dp已经写出来了,直接给转移方程:dp[ i ] = min(dp[ i - 1] + a[ i - 1] , dp[ i - 2] + b [ i - 2],我是从0为开始下标

代码:

扫描二维码关注公众号,回复: 2755610 查看本文章

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a) memset(a,-1,sizeof(a))
using namespace std;
const int maxn = 2005;
int dp[maxn],a[maxn],b[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while (t --)
    {
        mem(dp);
        int n,ans = 0;
        scanf("%d",&n); 
        for (int i = 0;i < n;i ++)
            scanf("%d",&a[i]);
        for(int i = 0;i < n - 1;i ++)
            scanf("%d",&b[i]);
        dp[0] = 0,dp[1] = a[0];
        for (int i = 2;i <= n;i ++)
            dp[i] = min(dp[i - 1] + a[i - 1],dp[i - 2] + b[i - 2]);
        ans = dp[n];
        int h = 8 + ans / 3600;    
        ans = ans - ans / 3600 * 3600;
        int min = ans / 60;
        ans = ans - ans / 60 * 60;
        int s = ans;
        printf("%.2d:%.2d:%.2d ",h,min,s);
        if (h >= 12) printf("pm\n");
        else printf("am\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81488368