HDU - 1260——Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
 
 

08:00:40 am 08:00:08 am


思路:dp。因为c[i]为第i个最优状态,a[i]为单个人领票时间,b[i]为第i和第i-1个人一起领票时间,则c[i]=min(c[i-1]+a[i],c[i-2]+b[i])。
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[2100],b[2100],c[2100];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        int shi,fen,miao;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=2;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        c[1]=a[1],c[2]=min(a[1]+a[2],b[2]);
        for(int i=3;i<=n;i++)
        {
            c[i]=min(c[i-1]+a[i],c[i-2]+b[i]);
        }
        shi=c[n]/3600+8;
        c[n]%=3600;
        fen=c[n]/60;
        c[n]%=60;
        miao=c[n];
        if(shi<12)
        printf("%02d:%02d:%02d am\n",shi,fen,miao);
        else
            printf("%02d:%02d:%02d pm\n",shi,fen,miao);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80369801