sdut_2134_数据结构实验之栈与队列四:括号匹配

数据结构实验之栈与队列四:括号匹配

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

Input

 输入数据有多组,处理到文件结束。

Output

 如果匹配就输出“yes”,不匹配输出“no”

Sample Input

sin(20+10)
{[}]

Sample Output

yes
no

Hint

Source

ma6174

思路很简单 就是从栈顶匹配括号   注意:只要有一组括号不是匹配的 整个字符串的括号就不是匹配的!!

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    int i, top, l;
    char a[55], b[55];
    while(gets(a))
    {
        top = 0;
        l = strlen(a);
        for(i = 0; i < l; i++)
        {
            if(a[i] == '(' || a[i] == '[' || a[i] == '{')
                b[++top] = a[i];
            if(a[i] == ')' || a[i] == ']' || a[i] == '}')
            {
                if((b[top] == '(' && a[i] == ')') || (b[top] == '[' && a[i] == ']') || (b[top] == '{' && a[i] == '}'))
                    top--;
                else
                    break;
            }
        }
        if(top == 0 && i == l)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/strongerXiao/article/details/81352857