字符串 || 字典树判断哈夫曼编码

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the
prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that
no two codes within a set of codes are the same, that each code has at least one bit and no more than
ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a
group contains a collection of zeroes and ones representing a binary code for a different symbol. Each
group is followed by a single separator record containing a single 9; the separator records are not part
of the group. Each group is independent of other groups; the codes in one group are not related to
codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately
decodable, and should print a single output line giving the group number and stating whether the
group is, or is not, immediately decodable.
Note: The Sample Input describes the examples above.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable

Set 2 is not immediately decodable


#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
struct Node{
	int ch[2]={0};
	int cn=0;
};
int cn;
bool ans;
Node node[10005<<1];
void insertn(char*x){
	int cur=1;
	for(int i=0;i<strlen(x);i++){
		if(node[cur].ch[x[i]-'0']==0){
			node[cur].ch[x[i]-'0']=++cn;		
		}
		cur=node[cur].ch[x[i]-'0'];
	}
	node[cur].cn++;
}
bool find(char*x){
	int cur=1;
	for(int i=0;i<strlen(x);i++){
		if(node[cur].cn!=0)return false;
		if(node[cur].ch[x[i]-'0']==0)return true;
		cur=node[cur].ch[x[i]-'0'];
	}
	if(node[cur].cn==1)return true;
	else return false;
}
int main(){
	char s[10005][105];
	int t=0;
	while(~scanf("%s",&s[0])){
		memset(node,0,sizeof(node));
		t++;
		cn=1;
		ans=1;
		insertn(s[0]);
		int n=1;
		while(1){
			scanf("%s",&s[n]);
			if(s[n][0]=='9')break;
			insertn(s[n]);
			n++;			
		}
		for(int i=0;i<n;i++){
			if(find(s[i])==false)ans=0;
		}
		if(ans)printf("Set %d is immediately decodable\n",t);
		else printf("Set %d is not immediately decodable\n",t);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/bekote/article/details/79733514
今日推荐