S-Nim

Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

Sample Input

 

2 2 5

3

2 5 12

3 2 4 7

4 2 3 7 12

5 1 2 3 4 5

3 2 5 12

3 2 4 7

4 2 3 7 12

0

Sample Output

 

LWW

WWL

sg[x]=mex(sg[y]|y为x的后继)。

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
queue<char>q;
int op[105];
int k;
int sg[10005];
int Hash[10005];

//sg函数模板
void sg_solve(int *s,int t,int N)
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1;i<=N;i++)//递推打表过程
    {
        memset(Hash,0,i+1);
        for(j=0;j<t;j++)
            if(i - s[j] >= 0)
                Hash[sg[i-s[j]]] = 1;//标记后继
        以下通过标记得出mex
        for(j=0;j<=N;j++)
            if(!Hash[j])
                break;
        sg[i] = j;
    }
}

/*int mex(int x){
    if(sg[x] != -1) return sg[x];
    bool vis[1005];
    for(int i = 0;i < 1005;i++)
        vis[i] = false;
    for(int i = 0;i < k;i++){
        int temp = x-op[i];
        if(temp < 0) break;
        sg[temp] = mex(temp);
        vis[sg[temp]] = true;
    }
    for(int i = 0;;i++)
    if(!vis[i]) {sg[x] = i;break;}
    return sg[x];
}*///令一个模板,没看懂。

int main()
{

	while(scanf("%d",&k)!=EOF&&k!=0)
	{	
		for(int i=0;i<k;i++)
		{
			scanf("%d",&op[i]);
		}
		
		
		sg_solve(op,k,10005);
		
		int m;
		scanf("%d",&m);
		
		while(m--)
		{
			int sum=0;
			int x;
			scanf("%d",&x);
			while(x--)
			{
			int mm;
			scanf("%d",&mm);
			sum=sum^sg[mm];
			}
			
		if(sum==0)
		q.push('L');
		else
		q.push('W');
		}
		while(!q.empty())
		{
			printf("%c",q.front());
			q.pop();
		}
	printf("\n");
	}
 } 

猜你喜欢

转载自blog.csdn.net/s_h_w_s_n_g/article/details/81317192
Nim