杭电第三场Ascending Rating

Problem Description

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i -th contestant's QodeForces rating is ai .
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m , say [l,l+m−1] , and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1 and count=0 . Everytime he meets a contestant k with strictly higher rating than maxrating , he will change maxrating to ak and count to count+1 .
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count . Please write a program to figure out the answer.

 

Input

The first line of the input contains an integer T(1≤T≤2000) , denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD .
In the next line, there are k integers a1,a2,...,ak(0≤ai≤109) , denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<i≤n) are then produced as follows :

ai=(p×ai−1+q×i+r)modMOD


It is guaranteed that ∑n≤7×107 and ∑k≤2×106 .  

Output

Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1] .
For each test case, you need to print a single line containing two integers A and B , where :

AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)


Note that ``⊕ '' denotes binary XOR operation.  

Sample Input

 

1 10 6 10 5 5 5 5 3 2 2 1 5 7 6 8 2 9

 

Sample Output

 

46 11

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <set>
#include <vector>
using namespace std;
typedef long long ll;
#define re(ss,dd,ww) for(int ww=ss;ww<dd;++ww)
#define er(dd,ss,ww) for(int ww=dd;ww>=ss;--ww)
#define wl(ss) while(ss)
int a[10000010],b[10000010],rep[10000010],c[10000010];//b记录最大,rep记录下标,c记录次数 
int main(){
	int t;
	scanf("%d",&t);
	wl(t--){
		int n,m,k,q,p,r,mod;
		scanf("%d %d %d %d %d %d %d",&n,&m,&k,&p,&q,&r,&mod);
		re(1,k+1,i) scanf("%d",&a[i]);
		re(k+1,n+1,i) a[i]=((ll)1*a[i-1]*p+(ll)1*q*i+r)%mod;
		int s=1,d=1;//s记录当前最大值的位置,d记录符合单调的当前区间 
		er(n,1,i){
			while(s<d && a[rep[d-1]]<=a[i]){//如果a[i]大于等于前面严格单调的说明前面操作存在不合法
				d--;
			}
			rep[d++]=i;
			if(n-i+1>=m){//已经大于等余合法长度
			 	b[i]=a[rep[s]];
				c[i]=d-s;//得到合法单调长度
				if(rep[s]>=i+m-1){
					s++;
				}	
			}	 
		}
		ll A=0,B=0;
		re(1,n-m+2,i){
			A+=(b[i]^i);
			B+=(c[i]^i);
		} 
		printf("%lld %lld\n",A,B);
	}
}

猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/81298833
今日推荐