Training little cats

D - Training little cats

Time limit

2000 ms

Memory limit

65536 kB

OS

Linux

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea.
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

题意很简单但是我之前理解的有点误差,以为重复m次是每进行一次操作就重复,但是正确的理解是全部操作整体进行m次重复,由于m的数据较大,所以用矩阵快速幂,用矩阵快速幂的时候必须进行优化,否则会超时,我搜别的博客,发现代码都差不多,重要的就是数据范围的注意。

正确的代码如下

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    long long cp[110][110];
} s;
int n;
node juzhen(node a,node b)
{
    node c;
    memset(c.cp,0,sizeof(c.cp));
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            if(a.cp[i][j])//优化必不可少,否则会超时
            {
                for(int z=1; z<=n; z++)
                    c.cp[i][z]+=a.cp[i][j]*b.cp[j][z];
            }
        }
    }
    return c;
}
node mul(int m)
{
    node ans;
    memset(ans.cp,0,sizeof(ans.cp));
    for(int i=1; i<=n; i++)
        ans.cp[i][i]=1;
    while(m)
    {
        if(m%2)
            ans=juzhen(ans,s);
        m>>=1;
        s=juzhen(s,s);
    }
    return ans;
}
int main()
{
    int k,b,c;
    long long m;
    char a[10];
    while(~scanf("%d%lld%d",&n,&m,&k))
    {
        if(n==m&&m==k&&k==0)
            break;
        n++;
        memset(s.cp,0,sizeof(s.cp));
        for(int i=1; i<=n; i++)
            s.cp[i][i]=1;
        while(k--)
        {
            scanf("%s%d",a,&b);
            if(a[0]=='g')
            {
                s.cp[b][n]++;
            }
            else if(a[0]=='e')
            {
                for(int j=1; j<=n; j++)
                    s.cp[b][j]=0;
            }
            else
            {
                scanf("%d",&c);
                for(int j=1; j<=n; j++)
                {
                    long long d;
                    d=s.cp[b][j];
                    s.cp[b][j]=s.cp[c][j];
                    s.cp[c][j]=d;
                }
            }
        }
        node p=mul(m);
        for(int i=1; i<n; i++)
            printf("%lld ",p.cp[i][n]);
        printf("\n");
    }
    return 0;
}


再贴出我之前思路错的代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long s[110];
int main()
{
    int n,m,k,b,c;
    char a[10];
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        if(n==m&&m==k&&k==0)
            break;
        memset(s,0,sizeof(s));
        while(k--)
        {
            scanf("%s%d",a,&b);
            if(a[0]=='g')
                s[b]+=m;
            else if(a[0]=='e')
                s[b]=0;
            else
            {
                scanf("%d",&c);
                if(m%2)
                {
                    int d;
                    d=s[b];
                    s[b]=s[c];
                    s[c]=d;
                }
            }
        }
        for(int i=1; i<n; i++)
            printf("%lld ",s[i]);
        printf("%lld\n",s[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41129854/article/details/81476179