POJ 2081 Recaman's Sequence(哈希模拟)(水题)

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate ak.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing ak to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

题目大意:第0项为0,如果第m-1项-m>0且该数未出现过,第m项为第m-1项-m,否则为第m-1项+m;

思路:谁把这题放在dp专题的........太不靠谱了,hash表标记一下出现状态直接模拟。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[500005]={0};
int p[10000000]={0};
int main()
{
    int i;
    for(i=1;i<=500000;i++)
    {
        if(a[i-1]-i>0&&p[a[i-1]-i]==0)
        {
		   a[i]=a[i-1]-i;
	    }
        else{
        a[i]=a[i-1]+i;
        p[a[i]]=1;
        } 
    }
    while(~scanf("%d",&i),i>=0)
    printf("%d\n",a[i]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/81391480