【题解】HDU 1263 水果

目录

题目描述

题意分析

AC代码


 

题目描述

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.

Input

第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.

Sample Input

1 5 apple shandong 3 pineapple guangdong 1 sugarcane guangdong 1 pineapple guangdong 3 pineapple guangdong 1

Sample Output

guangdong

         |----pineapple(5)

         |----sugarcane(1)

shandong 

         |----apple(3)

题意分析

题意:给出数据按照排版输出,十分好的一道STL操作题,增强了对二维MAP的理解。二个数据中还要多输出一个空行


AC代码

#include <iostream>
#include <algorithm>
#include <map>
using namespace std;

map <string,map<string,int> > s1;               //二维MAP
map <string,map<string,int> >::iterator it1;

map <string,int> s2;                            //第二元素
map <string,int>:: iterator it2;

int main()
{
    int t,n,i,num;
    string a,b;

    cin>>t;
    while(t--)
    {
        s1.clear();
        s2.clear();

        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>a>>b>>num;
            s1[b][a] += num;
        }
        for(it1 = s1.begin() ; it1 != s1.end(); it1++)
        {
            cout<<it1->first<<endl;
            s2 = it1->second;                              //映射
            for(it2 = s2.begin() ; it2 != s2.end();it2++)
            {
                cout<<"   |----"<<it2->first<<"("<<it2->second<<")"<<endl;
            }
        }
        if(t)
        {
            cout<<endl;         //PE注意
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41220023/article/details/81361141