1047 Student List for Course (25) mark

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

书上和百度的最后一个都超时,改了半天也没过先 mark这里

#include<cstdio>  
#include<cstring>  
#include<vector>
#include<fstream>
#include<algorithm>  
using namespace std;
const int maxn=40010;
const int maxc=2510;

char name[maxn][5];
vector<int> course[maxc];
int getid(char name[]){
	int id=0;
	for(int i=0; i<3; i++){
		id=id*26+(name[i]-'A');
	}
	id=id*10+(name[3]-'0');
	return id;
}
int main(){
	int n, k, c, courseid;
//	freopen("d://in.txt","r",stdin);
	scanf("%d%d", &n, &k);
	for(int i=0; i<n; i++){
		scanf("%s%d", name[i], &c);
		for(int j=0; j<c; j++){
			scanf("%d", &courseid);
			int id=getid(name[i]);
			course[courseid].push_back(id) ;
		}
	}
	for(int i=1; i<=k; i++){
		printf("%d %d\n", i, course[i].size() );
		sort(course[i].begin(), course[i].end());
		for(int j=0; j<course[i].size(); j++){
			int key=course[i][j];
			char s[4];
			s[0]=key/(26*26*10)+'A';
			key%=(26*26*10);
			s[1]=key/(26*10)+'A';
			key%=(26*10);
			s[2]=key/(10)+'A';
			s[3]=key%10+'0';	
			s[4]='\0';		
			printf("%s\n", s);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/81317047