未通过——1047 Student List for Course (25)

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

一个偷懒的写法, 牛客网通过了, 但是PAT最后一个数据运行超时了
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 40010;
const int M = 26 * 26 * 26 * 10 + 1;
vector<int> course[2510]; 
int change(char name[]) {
    int id = 0;
    for (int i = 0; i < 3; i++) {
        id = id * 26 + (name[i] - 'A');
    }
    id = id * 10 + (name[3] - '0');
    return id;
}
char str[M][5];  //注意这里要用M

int main() {
    int n, m, k;  //k为学生选课数
    char name[5];
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) {
        scanf("%s %d", name, &k);
        int id = change(name);
        for (int j = 0; j < k; j++) {
            int temp;
            scanf("%d", &temp);
            course[temp].push_back(id);
        }
        strcpy(str[id], name);  //strcy的赋值呀, 不要忘记写头文件
    }
    for (int i = 1; i <= m; i++) {
        printf("%d %d\n", i, course[i].size());
        sort(course[i].begin(), course[i].end());
        for (int j = 0; j < course[i].size(); j++) {
            printf("%s\n", str[course[i][j]]);
        }
    }
    return 0;
}

改进代码

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 40010;
const int M = 2510;
char name[N][5]; 
bool cmp(int a, int b) {
    return strcmp(name[a], name[b]) < 0;
}
vector<int> course[M];
int main() {
    int n, m, k, id;  //k为学生选课数
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) {
        scanf("%s %d", name[i], &k);
        for (int j = 0; j < k; j++) {
            scanf("%d", &id);
            course[id].push_back(i);
        }
    }
    for (int i = 1; i <= m; i++) {
        printf("%d %d\n", i, course[i].size());
        sort(course[i].begin(), course[i].end(), cmp);
        for (int j = 0; j < course[i].size(); j++) {
            printf("%s\n", name[course[i][j]]);
        }
    }
    return 0;
}

还是超时的, 第一次提交超时一个测试点, 第二次提交超时三个测试点, 第三次提交超时两个测试点。。。疯了。。。

猜你喜欢

转载自www.cnblogs.com/Yaxadu/p/9211098.html