POJ1701 Dissatisfying Lift

题目链接

Dissatisfying Lift

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5654   Accepted: 1282

Description

There's a building with M floors. The amounts of tenants of every floor are K1, K2, K3, ..., Km. One day all the tenants went home together and they took the same lift (suppose the lift was large enough). Because of some reason the lift could only stop on one floor and the tenants must go upstairs or downstairs to their houses. Every tenant went up N floors would make the dissatisfied degree rise N * a + 0.5 * N * (N - 1) degrees, and every tenant went down N floors would make the dissatisfied degree rise N * b + 0.5 * N * (N - 1) degrees. Your task is to tell which floor the lift should stop, in order to make the dissatisfied degree as low as possible.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each test contains M (1 <= M <= 10000), a and b (0 <= a, b <= 100). The second line contains K1, K2, K3, ..., Km (0 <= Ki <= 20, i = 1..M).

Output

For each test case, print a line containing a single integer, indicating which floor the lift should stop.

Sample Input

1
5 3 2
1 1 1 1 1

Sample Output

3

积累词汇:

tenant 英 [ˈtenənt]   美 [ˈtɛnənt] n.房客; 佃户;vt.租借,租用;

注意数据类型,不满意度要用long long。

推导公式如下:

上楼不满意度类似。

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int  T;
	cin>>T;
	while(T--)
	{
		int M,a,b,i;
		int k[10001];
		long long down[10001],up[10001];
		cin>>M>>a>>b;
		for(i=1;i<=M;i++) cin>>k[i];
		long long sum0=k[1],sum1=0;
		
		down[1]=0;
		for(i=2;i<=M;i++)//求下楼不满意度
		{
			down[i]=down[i-1]+b*sum0+sum1;
			sum1+=sum0;//这条语句和下面语句位置不能换
			sum0+=k[i];
		}
		
		sum0=k[M];sum1=0;
		up[M]=0;
		for(i=M-1;i>=1;i--)//求上楼不满意度
		{
			up[i]=up[i+1]+a*sum0+sum1;
			sum1+=sum0;
			sum0+=k[i];
		}
		
		long long min_d=down[1]+up[1],d=1;
		for(i=2;i<=M;i++)
		{
			if(down[i]+up[i]<min_d)
			{
				min_d=down[i]+up[i];//最小不满意度
				d=i;//楼层
			}
		}
		cout<<d<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40889820/article/details/81348260
今日推荐