Poj 27287 Desert King (01分数规划)

题目链接:http://poj.org/problem?id=2728

Desert King

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 29864   Accepted: 8230

Description

David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to every village. Villages which are connected to his capital village will be watered. As the dominate ruler and the symbol of wisdom in the country, he needs to build the channels in a most elegant way. 

After days of study, he finally figured his plan out. He wanted the average cost of each mile of the channels to be minimized. In other words, the ratio of the overall cost of the channels to the total length must be minimized. He just needs to build the necessary channels to bring water to all the villages, which means there will be only one way to connect each village to the capital. 

His engineers surveyed the country and recorded the position and altitude of each village. All the channels must go straight between two villages and be built horizontally. Since every two villages are at different altitudes, they concluded that each channel between two villages needed a vertical water lifter, which can lift water up or let water flow down. The length of the channel is the horizontal distance between the two villages. The cost of the channel is the height of the lifter. You should notice that each village is at a different altitude, and different channels can't share a lifter. Channels can intersect safely and no three villages are on the same line. 

As King David's prime scientist and programmer, you are asked to find out the best solution to build the channels.

Input

There are several test cases. Each test case starts with a line containing a number N (2 <= N <= 1000), which is the number of villages. Each of the following N lines contains three integers, x, y and z (0 <= x, y < 10000, 0 <= z < 10000000). (x, y) is the position of the village and z is the altitude. The first village is the capital. A test case with N = 0 ends the input, and should not be processed.

Output

For each test case, output one line containing a decimal number, which is the minimum ratio of overall cost of the channels to the total length. This number should be rounded three digits after the decimal point.

Sample Input

4
0 0 0
0 1 1
1 1 2
1 0 3
0

Sample Output

1.000

Source

Beijing 2005

题意:在这么一个图中求一棵生成树,这棵树的单位长度的花费最小是多少,每条边有两个权值cost和len。

求一个生成树使∑costi / ∑leni最小。

思路∑cost[i]  / ∑dis[i]  >= ans 变形可得 ∑(cost[i]-dis[i] * ans) >= 0;

cost[i]-dis[i]*ans就相当于最小生成树中的dis[i]; 二分ans即可。

Poj有毒G++就是不过 c++可以过

#include<bits/stdc++.h> 
using namespace std;
int n;
const double esp=1e-6;
const int MAX=1e3+10;
double a[MAX];
double b[MAX];
double c[MAX];
double Len[MAX][MAX];
double cost[MAX][MAX];
double dist[MAX];
int vis[MAX];
int check(double mid)//prim建树 
{
	memset(vis,0,sizeof(vis));
	vis[1]=1;
	double ans=0;
	for(int i=1;i<=n;i++)
		dist[i]= cost[1][i]-mid*Len[1][i];
	for(int i=2;i<=n;i++)
	{
		double flag=1e18;
		int Index=-1;
		for(int j=2;j<=n;j++)
		{
			if(vis[j]==0 && dist[j]<flag)
			{
				flag=dist[j];
				Index=j;
			}
		}
		if(Index==-1)
			break;
		vis[Index]=1;
		ans=ans+flag;
		for(int j=2;j<=n;j++)
			if(vis[j]==0 && cost[Index][j]-mid*Len[Index][j] < dist[j])
				dist[j] = cost[Index][j]-mid*Len[Index][j];
	}
	return ans>=0;//ans记录的建树的代价 
}

void solve()
{
	for(int i=1;i<=n;i++)
		scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			cost[i][j]=abs(c[i]-c[j]);//高度差
			Len[i][j]=(double)sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
		}
	}
	double l=0;
	double r=10000;
	while(r-l>esp)//二分 
	{
		double mid=(l+r)/2;
		if(check(mid))
			l=mid;
		else
			r=mid;	
	}
	printf("%.3lf\n",l);
}
int main ()
{
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		solve();
	} 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/passer__/article/details/81367140
今日推荐