C - Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

题目大意:

        将相邻的,对角的 @ 看成是一块区域,问矩阵中有一块这样的区域。

很典型的dfs,先搜索一块区域,并将这一块区域全部标记,表示已经搜索过,然后再从未搜索过的区域开始搜索,搜索一次则加一,就计算出来了。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<bits/stdc++.h>

using namespace std;
const int MAXN=1e2+5;
char s[MAXN][MAXN];
int vis[MAXN][MAXN];
int n,m,res;
int d[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,1,-1,-1,1,-1};

void dfs(int x,int y)
{
    vis[x][y]=0;   // 标记已经搜索过
    for(int i=0;i<8;i++){
        int nx=x+d[i][0],ny=y+d[i][1];
        if(nx>=0&&nx<n&&ny>=0&&ny<m&&s[nx][ny]=='@'&&vis[nx][ny]){
            dfs(nx,ny);
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)==2&&(n||m)){
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        memset(vis,1,sizeof(vis));
        res=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
             if(s[i][j]=='@'&&vis[i][j]){    // 还未搜索的区域
                res++;   // 一块区域加一
                dfs(i,j);
            }
        printf("%d\n",res);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hnlg311709000526/article/details/81331347