HDU: Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48759    Accepted Submission(s): 28044


 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

 

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output

 

0 1 2 2

Source

Mid-Central USA 1997

题意:寻找有多少石油连通块,@代表石油

思路:我们首先得找到一个起点,显然起点是一个位置上的字符为@,然后对其进行dfs,但这里却无需把标记还原,如果还原了标记也就无法知道哪些走过,而走过的是连在一起的石油块

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int n,m;
int dir[8][2]={{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}}; 
char map[105][105];
int book[105][105];
int ans = 0;

void dfs(int x,int y)
{
     for(int k = 0;k < 8;++k)
     {
     	int tx = x+dir[k][0];
     	int ty = y+dir[k][1];
     	if(tx < 1 || ty < 1 || tx > n || ty > m)  continue;
     	if(!book[tx][ty] && map[tx][ty] == '@')
     	{
     		book[tx][ty] = 1;
     		dfs(tx,ty);
     	}
     }
     return ;
}


int main()
{
    while(scanf("%d%d",&n,&m))
    {
    	if(n == 0 && m == 0)  break;
    	ans = 0; 
    	memset(book,0,sizeof(book));
    	for(int i = 1;i <= n;++i)
    	{
    		for(int j = 1;j <= m;++j)
    		   cin >> map[i][j];
    	}
    	
    	for(int i = 1;i <= n;++i)
    	{
    		for(int j = 1;j <= m;++j)
    		{
    			if(map[i][j] == '@' && !book[i][j])
    			{
    				 book[i][j] = 1;
    				 ans++;
    				 dfs(i,j);
    			}
    		}
    	}
    	printf("%d\n",ans);
    }
    
}

猜你喜欢

转载自blog.csdn.net/qq_40511966/article/details/88648073