Period (KMP数组求前缀)

题目:https://vjudge.net/contest/243048#problem/E

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
#include <iostream>
#include <string.h>
#include <stdio.h>
#define maxn 1000010
using namespace std;
int  fail[maxn];
char temp[maxn];
void getFail() {				    //求前缀
  int i = 0, j = -1;
	fail[0] = -1;
	while(temp[i]!= '\0') {
		if(j==-1 || temp[i]==temp[j])
		{
			++i, ++j;//相等的画,就向后移。
			int t=i-j;
			if(i%t==0&&i/t>1)printf("%d %d\n",i,i/t);//如果前缀是循环,并且循环节大于1;
			fail[i]=j;//更新初始位置
		}
		else j = fail[j];//不等就返回。
	}
}

int main()
{
    int n;
    int Case=0;
    while(scanf("%d",&n)==1&&n)
    {
            scanf("%s",temp);
            printf("Test case #%d\n",++Case);
            getFail();
            printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81364690