HDU 1019 Least Common Multiple

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
 
  
2
3 5 7 15
6 4 10296 936 1287 792 1
 

Sample Output
 
  
105
10296

求连续多个数的最小公倍数。

#include <iostream>
#include <algorithm>
using namespace std;
int main() {
	long long t, n, x;
	cin>>t;
	while(t--) {
		cin>>n;
		n--;
		cin>>x;
		long long f = x;
		while(n--) {
			cin>>x;
			f = f*x/(__gcd(f, x));
		}
		cout<<f<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/adusts/article/details/80671925