DP三连

(A)–POJ1163 The Triangle

传送门

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 
Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output

30

找状态转移方程:从后往前找最大
t[i][j] += max(t[i+1][j],t[i+1][j+1])
终态:
t[1][1]

#include <stdio.h>
#include <algorithm>
using namespace std;
int main()
{
    int n,t[128][128];
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
        for(int j=1; j<=i; j++)
            scanf("%d",&t[i][j]);
    for(int i=n-1; i>=1; i--)
        for(int j=1; j<=i; j++)
            t[i][j] += max(t[i+1][j],t[i+1][j+1]);
    printf("%d\n",t[1][1]);
    return 0;
}

(B)–POJ1458 Common Subsequence

传送门

Common Subsequence
Time Limit: 1000MS      Memory Limit: 10000K
Total Submissions: 60695        Accepted: 25361
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output

4
2
0

典型的LCS
状态转移方程:
这里写图片描述
终态:
ans[lenA][lenB]
千言万语不如一张图
这里写图片描述

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
    char a[1024],b[1024];
    int ans[512][512];
    while(~scanf("%s%s",a,b))
    {
        int lenA = strlen(a),lenB = strlen(b);
        for(int i=0; i<lenA; i++)
            ans[i][0] = 0;
        for(int i=0; i<lenB; i++)
            ans[0][i] = 0;
        for(int i=1; i<=lenA; i++)
            for(int j=1; j<=lenB; j++)
                if(a[i-1]==b[j-1])
                    ans[i][j] = ans[i-1][j-1]+1;
                else
                    ans[i][j] = max(ans[i-1][j],ans[i][j-1]);
        printf("%d\n",ans[lenA][lenB]);
    }
    return 0;
}

(C)–CSU1047 最长上升子序列

传送门

Description
  名词解释:

一串数字比如15369810,它的子序列是从左到右不连续的若干个数,比如15639810都是它的子序列。

最长上升子序列即从左到右严格增长的最长的一个子序列,156910就是这个序列的一个最长上升子序列。

给出若干序列,求出每个序列的最长上升子序列长度。

Input
  多组数据,每组第一行正整数n,1 <= n <= 1000,第二行n个空格隔开的不大于1,000,000的正整数。

Output
 每组数据输出一行,最长上升子序列的长度。

Sample Input
7
1 5 3 6 9 8 10
Sample Output
5

状态转移方程:
dp[i] = max(dp[i],dp[j]+1)
终态:
max(dp[i])

#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

int main()
{
    int a[1024],dp[1024],n,ans;
    while(~scanf("%d",&n))
    {
        ans = 0;
        for(int i=0;i<n;i++)
            dp[i] = 1;
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<i; j++)
                if(a[i]>a[j])
                    dp[i] = max(dp[i],dp[j]+1);
        for(int i=0; i<n; i++)
            ans = max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tilmant/article/details/81271810