Sudoku

Sudoku
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: System Crawler  (2018-07-15)

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
代码写的很烂 ,dfs暴力!!
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
int hang[10][10]={0};
int lie[10][10]={0};
int ge[10][10]={0};
int mp[10][10]={0};
int sum,flag=0;
void dfs(int i,int j)
{
	
	if(mp[i][j]!=0)
	{
		if(i==9&&j==9)
   			{
   				flag=1;
   				return;
			}
		if(j<9)
		dfs(i,j+1);
		else dfs(i+1,1);
	}
   	else
   		for(int k=1;k<10;k++)
   		{
   			if(ge[(i-1)/3*3+(j-1)/3+1][k]==0&&lie[j][k]==0&&hang[i][k]==0)
   			{
	   			hang[i][k]=1;
	   			lie[j][k]=1;
	   			ge[(i-1)/3*3+(j-1)/3+1][k]=1;
	   			mp[i][j]=k;
	   			if(i==9&&j==9)
	   			{
	   				flag=1;
	   				return;
				}
	   			if(mp[i][j]!=0)
				{
					if(j<9)
					dfs(i,j+1);
					else dfs(i+1,1);
					if(flag==1) return;
				}
	   		    
	   			mp[i][j]=0;
	   			hang[i][k]=0;
	   			lie[j][k]=0;
	   			ge[(i-1)/3*3+(j-1)/3+1][k]=0;
			}
		}
}
int main()
{
   int t;
   cin>>t;
   while(t--)
   {
   	sum=0;
   	flag=0;
   	memset(hang,0,sizeof(hang));
   	memset(lie,0,sizeof(lie));
   	memset(ge,0,sizeof(ge));
   	char s[10][10];
   	for(int i=0;i<9;i++)
   	{
   	   	scanf("%s",s[i]);
	}
   	for(int i=1;i<10;i++)
   	{
   		for(int j=1;j<10;j++)
   		{
   			mp[i][j]=s[i-1][j-1]-'0';
   			if(mp[i][j]==0)
   			sum++;
   			else{
   				hang[i][mp[i][j]]=1;
	   			lie[j][mp[i][j]]=1;
	   			ge[(i-1)/3*3+(j-1)/3+1][mp[i][j]]=1;
			   }
   			
		}
		
	}
	dfs(1,1);

	for(int i=1;i<10;i++)
   	{
   		for(int j=1;j<10;j++)
   		{
   			
   			cout<<mp[i][j];
		}
		cout<<endl;
		
	}
   }
} 



猜你喜欢

转载自blog.csdn.net/qq_38570571/article/details/81058901
今日推荐