Sudoku——poj2676

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

/*
111222333
111222333
111222333
444555666
444555666
444555666
777888999
777888999
777888999
9*9格的k个3*3分布 
当i(1~9),j(1~9)有k= 3*((x-1)/3)+(y-1)/3; 
*/ 
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
char s[10];
int a[10][10];
int b[10][10],c[10][10];//b[x][y],第x行y数是否已有,c[x][y]第x列j数是否已有 
int we[10][10];//k个3*3的格
int dfs(int x,int y){
	if(x==10){
		//再到则返回可以找到 
		return 1;
	}
	int f=0;
	if(a[x][y]){
		if(y==9){//下一个是下一行的第一个 
			f=dfs(x+1,1);
		}
		else{
			f=dfs(x,y+1);
		}
		return f;
	}
	int k=3*((x-1)/3)+(y-1)/3;
	for(int i=1;i<=9;i++){
		if(b[x][i]==0 && c[y][i]==0 && we[k][i]==0){
			b[x][i]=1;
			c[y][i]=1;
			we[k][i]=1;
			a[x][y]=i;
			if(y==9){
				f=dfs(x+1,1);
			}
			else{
				f=dfs(x,y+1);
			}
			if(f==1){//放在回溯赋值的前面,不然会造成赋值了又复原 
				return 1;
			} 
			a[x][y]=0;
			b[x][i]=0;
			c[y][i]=0;
			we[k][i]=0;
		}
	}
	return 0;
} 
int main(){
	int t;
	scanf("%d",&t);
	getchar();
	while(t--){
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		memset(we,0,sizeof(we));
		for(int i=1;i<=9;i++){
			gets(s);
			for(int j=1;j<=9;j++){
				a[i][j]=s[j-1]-'0';
				if(a[i][j]!=0){
					b[i][a[i][j]]=1;
					c[j][a[i][j]]=1;
					int k=3*((i-1)/3)+(j-1)/3;
					we[k][a[i][j]]=1; 
				}
			}
		}
		dfs(1,1);
		for(int i=1;i<=9;i++){
			for(int j=1;j<=9;j++)
				printf("%d",a[i][j]);
			printf("\n");
		}
	}
} 

猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/81057153