【HDU 1241 --- Oil Deposits】DFS

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_41879343/article/details/102686846

【HDU 1241 --- Oil Deposits】DFS


Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

解题思路

采用深度优先搜索,从任意的@开始,不断把邻接的部分用’‘代替,1次DFS后与初始这个@连接的所有@就全都被替换成’’,因此直到图中不再存在W为止,总共进行DFS的次数就是答案。

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 105;
int n,m,ans;
char str[MAXN][MAXN];
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}};

void dfs(int x,int y)
{
    str[x][y]='*';
    for(int i=0;i<8;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&str[dx][dy]=='@')
            dfs(dx,dy);
    }
}

int main()
{  
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    while(cin >> n >> m && (n||m))
    {
        ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                cin >> str[i][j];
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(str[i][j]=='@')
                    dfs(i,j),ans++;
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/102686846