hdu 4288 Coder(STL)

Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6452    Accepted Submission(s): 2400


Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by

  where the set S is written as {a 1, a 2, ... , a k} satisfying a 1 < a 2 < a 3 < ... < a k 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 10 5 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 10 9.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

Sample Input
 
  
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output
 
  
3 4 5
Hint
C++ maybe run faster than G++ in this problem.
 

Source
 

Recommend
liuyiding

题意:

有三个操作

1是在集合中加入一个数

2是在集合中删除一个数

3是求这个和

思路:

每次删除和加入的时候用二分找到相应删除和加入的位置然后进行操作,这样可以保持数组是升序的。

然后用vector的insert和erase的函数就可以动态的维护这个数组。

求和的时候直接暴力。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long ll;
vector<int> v;
vector<int>::iterator it;
int main()
{
    int n,x;
    char op[5];
    while(~scanf("%d",&n))
    {
        v.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",op);
            if(op[0]=='a')
            {
                scanf("%d",&x);
                it=lower_bound(v.begin(),v.end(),x);
                v.insert(it,x);
            }
            else if(op[0]=='d')
            {
                scanf("%d",&x);
                it=lower_bound(v.begin(),v.end(),x);
                v.erase(it);
            }
            else
            {
                if(v.size()==0)
                    printf("0\n");
                else
                {
                    ll sum=0;
                    for(int j=2;j<v.size();j+=5)
                    {
                        sum+=v[j];
                    }
                    printf("%lld\n",sum);
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/timeclimber/article/details/80056753