Coder HDU - 4288

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_40758751/article/details/82380266

Coder

HDU - 4288

  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by


  where the set S is written as {a 1, a 2, ... , a k} satisfying a 1 < a 2 < a 3 < ... < a k
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm

Input

  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 10 5 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 10 9.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).

Output

  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.

Sample Input

9
add 1
add 2
add 3
add 4
add 5
sum
add 6
del 3
sum
6
add 1
add 3
add 5
add 7
add 9
sum

Sample Output

3
4
5

        
  

Hint

C++ maybe run faster than G++ in this problem.
        
 AC代码
//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
//#define sddd(x,y,z) scanf("%d%d%d", &x, &y, &z)
#define sdd(x,y) scanf("%d%d", &x, &y)
#define sd(x) scanf("%d", &x)
//#define mp make_pair
#define pb push_back

using namespace std;
typedef long long ll;
#define MOD 1000000007
const int maxn = 100111;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
int n, m, t, _n;
struct node
{
    int num;
    ll sum[5];
};
node dat[maxn<<2];
ll arr[maxn];
struct Q
{
    char q[10];
    ll n;
};
Q que[maxn];
void init(int _n)
{
    n = 1;
    while(n<_n) n<<=1;
    for(int i = 0; i < n*2-1; i++)
    {
        dat[i].num = 0;
        memset(dat[i].sum, 0, sizeof dat[i].sum);
    }
}
void update(int k, int val)
{
    k += n-1;
    dat[k].num = val;
    if(val)
        dat[k].sum[0] = arr[k-n+1];
    else
        dat[k].sum[0] = 0;
    while(k)
    {
        k = (k-1)/2;
        dat[k].num = dat[k*2+1].num + dat[k*2+2].num;
        for(int i = 0; i < 5; i++)
            dat[k].sum[i] = dat[k*2+1].sum[i] + dat[k*2+2].sum[((i-dat[k*2+1].num)%5+5)%5];
    }
}

int main()
{
	//freopen("in.txt", "r", stdin);
	while(~scanf("%d", &_n)&&_n)
    {
        int len = 0;
        for(int i = 0; i < _n; i++)
        {
            scanf("%s", que[i].q);
            if(que[i].q[0]!='s')
            {
                sd(que[i].n);
                arr[len++] = que[i].n;
            }
        }
        sort(arr, arr+len);
        int nn = unique(arr, arr+len) - arr;
        init(nn);
        for(int i = 0; i < _n; i++)
        {
            if(que[i].q[0] == 's')
                printf("%lld\n", dat[0].sum[2]);
            else if(que[i].q[0] == 'a')
            {
                int k=(int)(lower_bound(arr,arr+nn,que[i].n)-arr);
                update(k, 1);
            }
            else
            {
                int k=(int)(lower_bound(arr,arr+nn,que[i].n)-arr);
                update(k, 0);
            }
        }
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/82380266