PAT 乙级(B 1020) 月饼

题目要求:(pat B1020)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

 算法思路:

这到题中,我们需要建立一个月饼结构体,来保存他的库存、总价和单价(后面需要根据单价来对月饼种类进行排序,以获得最大收益)。并声明一个BILL数组来存储输入的月饼的信息。

struct MoonCake{
	double inventory; //库存量
	double unitPrice;//单价
	double totalPrice;
}bill[CLASS+10];

这道题我们优先选择其中单价比较大的月饼种类销售。也就是指我们需要根据单价来对月饼进行排序。

 

代码展示: 

#include <algorithm>
#include <cstdio>
using namespace std;
#define CLASS 1000
struct MoonCake{
	double inventory; //库存量
	double unitPrice;//单价
	double totalPrice;
}bill[CLASS+10];

bool cmp(MoonCake a,MoonCake b){
	return a.unitPrice>b.unitPrice;
}


int main(){
	int num,sum;
	scanf("%d %d",&num,&sum);
	for(int i=0 ; i< num; i++){
		scanf("%lf",&bill[i].inventory);
	}

	for(int i=0;i<num;i++){
		scanf("%lf",&bill[i].totalPrice);
		bill[i].unitPrice = bill[i].totalPrice / bill[i].inventory;
	}
	
	sort(bill,bill+num,cmp);
	double count = 0;
	int i = 0;
	double income = 0;

	while(count < sum){
		if(i>num){
			printf("%.2f\n",income);
			return 0;
		}
		int temp = sum - count ;
		if(temp>bill[i].inventory){
			count += bill[i].inventory;
			income += bill[i].totalPrice;
		}
		else{
			count += temp;
			income += temp * bill[i].unitPrice;
		}
		i++;
	}
	printf("%.2f\n",income);
	return 0;
}

注意:

  • 注意读题,确定每个数据的类型,除了整数之外都为double
  • C++不同类型scanf和printf对应的符号一定要正确,不然不能正确读取。
数据类型 scanf 格式符 printf 格式符
int %d %d
long long %lld %lld
float %f %f
double %lf %f
char %c %c
string(char数组) %s %s
  • 注意把情况都考虑到(出错处理)

比如本题中要考虑月饼库存量的总和小于市场要求的总量 的情况。但是,在pat中除了特殊要求之外是必须要返回0的,所以在适当的位置判断并返回结果。

int i = 0;//代表当前遍历的月饼种类。
if(i>num){
    printf("%.2f\n",income);
	return 0;
}
  •  sort排序函数的使用可以参考我的另一篇博客

                     https://blog.csdn.net/qq_34801341/article/details/81176026

转载请声明!!!

猜你喜欢

转载自blog.csdn.net/qq_34801341/article/details/81200523
今日推荐