HDU - 4763 Theme Section(kmp)

It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ - ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
Sample Input

5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output

0
0
1
1
2

题解:
(。。。解什么解。。。一堆奇奇怪怪的bug,改的都和别人的一样了,,,看我那乱七八糟的找bug啊,,,真的,,,今天的题对我一点都不友好,,,难受)
题目要求求出满足EAEBE格式的最长的E的长度。我们可以通过枚举所有的前缀后缀公共部分然后再看中间是否有该公共部分。

#include<bits/stdc++.h>
using namespace std;

#define ll long long
#define M 1000050
int ne[M];
char s1[M];
char s2[M];
char b[M];

void getnext(char *b){
    int len = strlen(b);
    int i=0, j=-1;
    ne[0] = -1;
    while(i < len){
        if(j == -1 || b[i] == b[j]){
            ne[++i] = ++j;
        }
        else
            j = ne[j];
    }
}

int main(){
    //cout << '1' << endl;
    int T, i, n, po;
    //cout << '1' << endl;
    scanf("%d", &T);
    //cout << '1' << endl;
    while(T--){
        scanf("%s", b);
        memset(ne, 0, sizeof(ne));
        getnext(b);
        n = strlen(b);
        po = ne[n];
        //cout << po << endl;
        while(po > n/3){
            po = ne[po];
           // cout << po << endl;
        }
        while(1){
            memset(s1, 0, sizeof(s1));
            memset(s2, 0, sizeof(s2));
            strncpy(s1, b, po);//将b所在的字符串的以b为地址往后的po个字符都复制s1
            strncpy(s2, b+po, n-po);
            //看中间部分是否存在该前缀
            if(strstr(s2, s1))
                break;
            else
                po = ne[po];
        }
        printf("%d\n", po);
//        bool flag = 1;
//        for(i=1; b[i]!= '\0'; i++){
//            if(ne[i+1] - ne[i] != 1 && ne[i] != -1){
//                s = max(s, ne[i]);
//                flag = 0;
//                //cout << flag << endl;
//            }
//        }
//        //cout << flag << endl;
//        if(flag)
//            printf("%d\n", strlen(b)/3);
//        else{
//            if(ne[i] >= s)
//                printf("%d\n", s);
//            else
//                printf("%d\n", ne[i]);
//        }
    }
    return 0;
}

实在搞不懂为什么必须要把s1,s2提到主函数外,,,

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81182006