(KMP)hdu4763 Theme Section

Theme Section

Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
 
  
5xyabcaaaaaaabaaaxoaaaaa
 

Sample Output
 
  
00112
 
 
//满足EAEBE的形式(A,B为任意字符),求E的最大长度.
/*思路:首先用nxt[]求出,前后缀匹配的最大长度,之后再一次求出中间串和前缀匹配(最大长度是nxt[len],不满足条件的话,进行回溯len=nxt[len])的最大长度,此时求得结果即为答案。
  */
#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<string.h>
using namespace std;
const int maxn=1e6+10;
int nxt[maxn],len;
char str[maxn];

void getNext()
{
    nxt[0]=-1;
    int i=0,j=-1;
    while(i<len){
        if(j==-1||str[i]==str[j])
            nxt[++i]=++j;
        else
            j=nxt[j];
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",str);
        len=strlen(str);
        getNext();
        int k=nxt[len],ans=0;
        while(k&&!ans){
            int i=k,j=0;
            while(i<len-k){
                if(j==k) break;
                if(j==-1||str[i]==str[j])
                    i++,j++;
                else
                    j=nxt[j];
            }
            if(j==k) ans=k;
            k=nxt[k];
        }
        printf("%d\n",ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_37275680/article/details/80150572