HDOJ.5327.Olympiad(前缀和)

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2353    Accepted Submission(s): 1433

 

Problem Description

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b). Please be fast to get the gold medal!

Input

The first line of the input is a single integer T (T≤1000), indicating the number of testcases. 

For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1≤a≤b≤100000.

Output

For each testcase, print one line indicating the answer. 

Sample Input

2 1 10 1 1000

Sample Output

10 738

Author

XJZX

Source

2015 Multi-University Training Contest 4

考点:前缀和

#include<iostream>
#include<cstring>
using namespace std;

int sum[100005]= {0};

int prefix(int n)  //判断beautiful number
{
    int a[10],k=0,cnt=0;
    while(n)
    {
        a[k++]=n%10;
        n/=10;
    }
    for(int i=0; i<k; i++)
    {
        for(int j=0; j<k,j!=i; j++)
        {
            if(a[i]==a[j])
                return 0;
        }
    }
    cnt++;
    return cnt;
}

int main()
{
    int T;
    cin>>T;
    memset(sum,0,sizeof(sum));
    for(int i=1; i<=100005; i++)
    {
        sum[i]=sum[i-1]+prefix(i);
    }
    while(T--)
    {
        int a,b,n,m;
        cin>>a>>b;
        n=min(a,b);
        m=max(a,b);
        cout<<sum[m]-sum[n-1]<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/81130642