A - Minimum Inversion Number (vj)

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 
a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 
You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

简直就是妙啊,树状数组用来求解区间和问题,用在此题,恰到好处。刚开始看到这题时,也是一头雾水。

1.树状数组下标必须从1开始

2.先求出初始的逆序对,sum(i)代表以i结尾的逆序对

3.cnt+=-a[i]+(n-a[i]+1);这个很关键,每当把a[i]从头部放到尾部去,逆序对发生的变化直接由a[i]算出

#include<bits/stdc++.h>
using namespace std;
int c[5005],a[5005],n;
int lowbit(int t)
{
    return t&(-t);
}
int sum(int pos)
{
    int ans=0;
    while(pos>0)
    {
        ans+=c[pos];
        pos-=lowbit(pos);
    }
    return ans;
}
void update(int pos,int val)
{
    while(pos<=n)
    {
        c[pos]+=val;
        pos+=lowbit(pos);
    }
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        int ans=0;
        memset(c,0,sizeof(c));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            a[i]++;
            ans+=sum(n)-sum(a[i]);
            update(a[i],1);
        }
        int cnt=ans;
        for(int i=0;i<n;i++)
        {
            cnt+=-a[i]+(n-a[i]+1);
            ans=min(ans,cnt);
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81190265