最大生成树模板 POJ-2377

 Bad Cowtractors

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int q[1005][1005],a,b;long long ans,flag;
const int INF=0x3f3f3f3f;
int d[1005];
bool v[1005];

void p(int x){
    memset(v,0,sizeof(v));
    for(int i=1;i<=a;i++)   d[i]=q[1][i];
    ans=0;
    v[1]=1;
    for(int i=1;i<a;i++){
        int u=-1,MIN=0;
        for(int j=1;j<=a;j++){
            if(v[j]==0&&d[j]>MIN)
                MIN=d[j],u=j;
        }
        ans+=MIN;
        //printf("%d\n",MIN);
        if(u==-1){
            flag=0;
            return ;
        }
        v[u]=1;
        for(int z=1;z<=a;z++){
            if(v[z]==0&&q[u][z]>d[z])
                d[z]=q[u][z];
        }
    }



}

int main(){
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d %d",&a,&b)){
        int i,j,x;
        memset(q,0,sizeof(q));
        while(b--){
            scanf("%d %d",&i,&j);
            scanf("%d",&x);
            if(x>q[i][j])
            q[i][j]=q[j][i]=x;
        }
        flag=1;
        p(1);
        if(flag==0) printf("-1\n");
        else
        printf("%d\n",ans);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41199327/article/details/81110769
今日推荐