7-10 集合相似度(25 分)


给定两个整数集合,它们的相似度定义为:Nc/Nt×100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M104),是集合中元素的个数;然后跟M[0,109]区间内的整数。

之后一行给出一个正整数K2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例:

50.00%
33.33%
#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;

int main()
{
	set<int> st[51];
	int n,m,i;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&m);
		while(m--)
		{
			int k;
			scanf("%d",&k);
			st[i].insert(k);
		} 
		
	}
	
	int c;
	scanf("%d",&c);
	while(c--)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		int cnt=0;
		for(set<int>::iterator it=st[a].begin();it!=st[a].end();it++)
		{
			if(st[b].count(*it))
			cnt++;
		}
		int sum=st[a].size()+st[b].size()-cnt;
		printf("%.2lf%%\n",cnt*100.0/sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39178993/article/details/79749034