2018 Multi-University Training Contest 1 1011 Time Zone 【模拟】

Time Zone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5204 Accepted Submission(s): 878

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of “UTC+X”, “UTC-X”, “UTC+X.Y”, or “UTC-X.Y” (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input

3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0

Sample Output

11:11
12:12
03:23

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
#define LL long long
const int maxn = 5000+3;
const double eps = 1e-8;

void check(int &hh,int &ff) {
    while(ff>=60) {
        ff-=60;
        hh+=1;
    }
    while(ff<0) {
        ff+=60;
        hh-=1;
    }
    while(hh>=24) {
        hh-=24;
    }
    while(hh<0) {
        hh+=24;
    }
}

int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        int hh,ff;
        scanf("%d%d",&hh,&ff);
        getchar();
        getchar();
        getchar();
        getchar();
        char f=getchar();
        int a;
        scanf("%d",&a);
        if(f=='-') a=-a;
        char c=getchar();
        if(c=='\n') {

            ff+=(a-8)*60;
        } else {
            int b;
            scanf("%d",&b);
            if(f=='-') b=-b;
            ff+=60*a+6*b-8*60;
        }
        check(hh,ff);
        printf("%02d:%02d\n",hh,ff);

    }


    return 0;
}

猜你喜欢

转载自blog.csdn.net/irish_moonshine/article/details/81190737