2018 Multi-University Training Contest 1(部分题解)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37444209/article/details/81749727

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3985    Accepted Submission(s): 926

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

3

1

2

3

Sample Output

-1

-1

1

题解:找规律,打个表就会发现,每个数的乘积的最大值都和3和4有关

打表:

#include<bits/stdc++.h>
#define ios1 ios::sync_with_stdio(0)
#define ios2 cin.tie(0)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;


int main (){
	int T, n;
	scanf("%d", &T);
	while(T--) {
		for(int r = 1; r <= 50; r ++){
			printf("n = %d\n", r);
			for(int i = 1; i <= n; i++) {
				if(r % i == 0) {
					for(int j = 1; j <= n; j++) {
						if(r % j == 0) {
							for(int k = 1; k <= n; k++) {
								if(r % k == 0){
									if((i + j + k) == r){
										int p = i * j * k;
										printf("i = %d j = %d k = %d p = %d\n", i, j, k, p);
									}
								}
							}
						}
					}
				}
			}
		}
	}
	return 0;
}

AC代码:

#include<bits/stdc++.h>
#define ios1 ios::sync_with_stdio(0)
#define ios2 cin.tie(0)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

int main() {
	int T;
	LL n;
	scanf("%d", &T);
	while(T--) {
		scanf("%lld", &n);
		if(n % 3 == 0) {
			LL k = n / 3;
			printf("%lld\n", k * k * k); 
		}
		else if(n % 4 == 0){
			LL k = n / 4;
			LL p = k * k * (n - 2 * k);
			printf("%lld\n", p);
		}
		else printf("-1\n");
	}
	return 0;
}

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 2174    Accepted Submission(s): 1102
Special Judge

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1

1

1 2

2 3

3 5

Sample Output

1  2  3 

题解:题中说明任意一组解即可,对横纵坐标排个序即可;

#include<bits/stdc++.h>
#define ios1 ios::sync_with_stdio(0)
#define ios2 cin.tie(0)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 3100;

struct node {
	int x, y, id;
}arr[maxn];

bool cmp (node p, node q) {
	if(p.x == q.x) return p.y < q.y;
	return p.x < q.x;
}

int main() {
	int T, n;
	scanf("%d", &T);
	while(T--) {
		scanf("%d", &n);
		n = 3 * n;
		for(int i = 1; i <= n; i++) {
			scanf("%d%d", &arr[i].x, &arr[i].y);
			arr[i].id = i;
		}
		sort(arr + 1, arr + 1 + n, cmp);
		for(int i = 3; i <= n; i+=3){
			printf("%d %d %d\n", arr[i-2].id, arr[i-1].id, arr[i].id);
		}
	}
	return 0;
}

Distinct Values

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4796    Accepted Submission(s): 1629

Problem Description

Chiaki has an array of n positive integers. You are told some facts about the array: for every two elements ai and aj in the subarray al..r (li<jr), aiaj holds.
Chiaki would like to find a lexicographically minimal array which meets the facts.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers n and m (1≤n,m≤105) -- the length of the array and the number of facts. Each of the next m lines contains two integers li and ri(1≤lirin).
It is guaranteed that neither the sum of all n nor the sum of all m exceeds 106.

Output

For each test case, output n integers denoting the lexicographically minimal array. Integers should be separated by a single space, and no extra spaces are allowed at the end of lines.

Sample Input

3 
2 1 
1 2 
4 2 
1 2 
3 4 
5 2 
1 3 
2 4

Sample Output

1 2

1 2 1 2

1 2 3 1 1

 

#include<bits/stdc++.h>
using namespace std;
#define ios1 std::ios::sync_with_stdio(false)
#define ios2 std::cin.tie(0)
#define inf 0x3f3f3f3f
#define ll long long
const int maxn = 1e5 + 10;
int que[maxn], ans[maxn];


int main(){
    int T, n, m;
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &n, &m);
        memset(que, 0, sizeof(que));
        set<int>s;
        for(int i = 1; i <= n; i++) {
            s.insert(i);
            que[i] = i;
        }
        int u, v;
        while(m--) {
            scanf("%d%d", &u, &v);
            que[u] = max(que[u], v);
        }
        int left = 1;
        for(int i = 1; i <= n; i++) {
            if(i != 1) {
                s.insert(ans[i-1]);
            }
            while(left <= que[i]) {
                ans[left] = *s.begin();
                s.erase(ans[left++]);
            }
        }
        for(int i = 1; i < n; i++) {
            printf("%d ", ans[i]);
        }
        printf("%d\n", ans[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37444209/article/details/81749727