2018 Multi-University Training Contest 1 Time Zone

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

Sample Output

 

11:11 12:12 03:23

简单模拟题

#include<bits/stdc++.h>

using namespace std;

int main()
{
    int T;
    scanf("%d" , &T);
    while(T --)
    {
        int h , m;
        char s[20];
        scanf("%d %d" , &h , &m);
        scanf("%s", s);
        int len = strlen(s);
        if(len == 5)
        {
            if(s[3] == '+')
            {
                h += (s[4] - '0' - 8);
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h ,m);
            }
            else if(s[3] == '-')
            {
                int temp = 8 + (s[4] - '0');
                h -= temp;
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h , m);
            }
        }
        else if(len == 6)
        {
            if(s[3] == '+')
            {
                h += ((s[4] - '0') * 10 + s[5] - '0' - 8);
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h ,m);
            }
            else if(s[3] == '-')
            {
                int temp = 8 + (s[4] - '0') * 10 + s[5] - '0';
                h -= temp;
                //h -= ((s[4] - '0') * 10 + s[5] - '0' - 8);
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h , m);
            }
        }
        else if(len == 7)
        {
            if(s[3] == '+')
            {
                int temp = s[6] - '0';
                temp *= 6;
                m += temp;
                if(m >= 60)
                {
                    h ++;
                    m -= 60;
                }
                temp = s[4] - '0' - 8;
                h += temp;
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h ,m);
            }
            else if(s[3] == '-')
            {
                int temp = s[6] - '0';
                temp *= 6;
                m -= temp;
                if(m < 0)
                {
                    h --;
                    m += 60;
                }
                temp = 8 + (s[4] - '0');
                h -= temp;
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n", h , m);
            }
        }
        else if(len == 8)
        {
           if(s[3] == '+')
            {
                int temp = s[7] - '0';
                temp *= 6;
                m += temp;
                if(m >= 60)
                {
                    h ++;
                    m -= 60;
                }
                temp = ((s[4] - '0') * 10 + s[5] - '0' - 8);
                h += temp ;
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h ,m);
            }
            else if(s[3] == '-')
            {
                int temp = s[7] - '0';
                temp *= 6;
                m -= temp;
                if(m < 0)
                {
                    h --;
                    m += 60;
                }
                temp = 8 + (s[4] - '0') * 10 + s[5] - '0';
                h -= temp;
                if(h < 0)
                    h += 24;
                h %= 24;
                printf("%02d:%02d\n" , h ,m);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ant_e_zz/article/details/81172107