POJ——1651 Multiplication Puzzle(区间dp)

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

题意:除两个端点外,那中间的数,得到一个值为:这个数乘以它旁边的数,然后去掉这个数,知道剩下两个端点的数为止,把得到的值相加,要求输出最小的和值。

题解:简单区间dp,解释看代码:

#include <iostream>
using namespace std;
const int MAX = 520;
const int inf = 0x3f3f3f3f;
int a[MAX],dp[MAX][MAX];
int  main(){
	int n;
	cin >> n;
	for (int i = 1; i <= n;i++) cin >> a[i];
	for (int i = 1; i <= n-2;i++){//不包括两个端点
		for (int j = 1;j+i+1 <= n;j++){//注意是j+i+1<=n,不要越界,越界也能过~~~~~~
			int ans=inf;//求最小值,初始化为最大值
			int r=j+i+1;//至少三个数
			for (int k = j+1;k <= r-1;k++){//枚举区间
				ans=min(ans,dp[j][k]+dp[k][r]+a[j]*a[k]*a[r]);
			}
			dp[j][r]=ans;
		}
	}
	cout << dp[1][n] << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lgz0921/article/details/84962759
今日推荐