Eight HDU - 1043

问题:

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

思路:

这个题也是参考的大佬的,就是从目标状态,去搜索每一种状态,然后把每一种状态和如何走到的路径留下来,

用到了map映照容器,用于储存每种状态和走到的路径。

代码:

#include<map>
#include<queue>
#include<string>
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sxy,net[4][2]= {0,1,0,-1,1,0,-1,0};
char dis[5]="lrud";
string db[200000];
int step=0;
map<int,int>se;
struct node
{
    int xy;
    int b;
    string ds;
};
void bfs()
{
    queue<node>q;
    node h,t;
    h.xy=8;
    h.b=123456789;
    h.ds="";
    se[h.b]=step++;
    db[se[h.b]]="";
    q.push(h);
    while(!q.empty())
    {
        h=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            t=h;
            int tx=h.xy/3+net[i][0];
            int ty=h.xy%3+net[i][1];
            if(tx<0||ty<0||tx>=3||ty>=3)
                continue;
            int d=tx*3+ty,k[10];
            for(int j=8; j>=0; j--)
            {
                k[j]=t.b%10;
                t.b=t.b/10;
            }
            int dk=k[d];
            k[d]=k[h.xy];
            k[h.xy]=dk;
            for(int j=0; j<9; j++)
                t.b=t.b*10+k[j];
            if(se.find(t.b)!=se.end())
                continue;
            t.ds=dis[i]+t.ds;
            se[t.b]=step++;
            db[se[t.b]]=t.ds;
            t.xy=d;
            q.push(t);
        }
    }
}
int main()
{
    char c;
    step=0;
    bfs();
    while(~scanf("%c ",&c))
    {
        int s=0;
        if(c=='x')
            s=9;
        else
            s=c-'0';
        for(int i=1; i<8; i++)
        {
            scanf("%c ",&c);
            if(c=='x')
                s=s*10+9;
            else
                s=s*10+(c-'0');
        }
        scanf("%c",&c);
        if(c=='x')
            s=s*10+9;
        else
            s=s*10+(c-'0');
        if(se.find(s)!=se.end())
            cout<<db[se[s]]<<endl;
        else
            cout<<"unsolvable"<<endl;
        getchar();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lxxdong/article/details/81159391