ACM 动态规划 POJ1042题目分析

题目原文:

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
Input
You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
Output
For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
Sample Input
2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 
Sample Output
45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

翻译:大致意思就是给你一段时间,在这段时间内你需要在n个鱼塘中捕鱼,并且使鱼量最大化。

解题思路:贪心思想+动态规划

依次求前i个湖能得到的最大鱼量,在求最大鱼量的过程中用贪心的思想,每次都选择可以捕到鱼最多,花费时间最少的鱼塘

这里用到了优先队列,相关知识可以查看博客点击打开链接

下面直接给出相关代码:

#include <iostream>
#include <stdio.h>
#include <queue>
#include <cmath>
#include <string.h>
#include <algorithm>

using namespace std;
struct lake
{
    int f;//鱼量
    int d;//减少量
    int id;//湖的编号
};
lake a[100];
int dist[100],tmp[100],best[100];
bool operator<(const lake &a,const lake &b)//贪心思想,每次都找最多,利用最少时间的
{
    if(a.f==b.f)
        return a.id>b.id;//如果两个湖鱼量相同,则直接按湖的编号顺序进行扑鱼
    else
        return a.f<b.f;//如果鱼量不同,则选择鱼量最大的先进行扑鱼
}
priority_queue<lake> q;
int main()
{
    int n,i,j,k;
    scanf("%d",&n);
    while(n!=0)
    {
        int time,ans=-100;
        scanf("%d",&time);
        time*=12;//以五为单位进行划分
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i].f);
            a[i].id=i;
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i].d);
        }
        dist[0]=0;//默认在第一个湖,所以距离设置为0
        for(i=1;i<n;i++)
        {
            scanf("%d",&dist[i]);
            dist[i]+=dist[i-1];//distance[i]表示从0到i的距离
        }
        for(i=0;i<n;i++)
        {
            int now=0;
            while(q.empty()==0)
            {
                q.pop();//清空队列
            }
            for(j=0;j<=i;j++)
            {
                q.push(a[j]);//全部入队
            }
            memset(tmp,0,sizeof(tmp));
            int tt=time-dist[i];
            while(tt>0)//按优先级一次进行扑鱼
            {
                lake node=q.top();
                q.pop();
                tt--;
                now+=node.f;
                node.f-=node.d;
                tmp[node.id]++;
                if(node.f<0)
                    node.f=0;
                q.push(node);//每次扑鱼后,都进行一次优先级的比较
            }
            if(now>ans)
            {
                ans=now;
                for(j=0;j<n;j++)
                {
                    best[j]=tmp[j];
                }
            }

        }
        for(i=0;i<n-1;i++)
            printf("%d, ",5*best[i]);
        printf("%d\n",5*best[n-1]);
        printf("Number of fish expected: %d\n",ans);
        scanf("%d",&n);
        if(n>0)
            printf("\n");

    }
    return 0;
}





猜你喜欢

转载自blog.csdn.net/qq_40774175/article/details/79703734