Q - A Knight's Journey

Q - A Knight's Journey

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

 注意:


1)定义方向数组,要按顺序:->{{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};


2)存路径要用两个数组,否则会 WA;


代码:

AC代码;
#include<queue>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int ne[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
char a[510],b[500];   //两个数组分别存字母,数字;
int p,q,flag=0,sum;
int book[88][88];
bool jud(int a,int b)
{
    if(a>=0&&a<p&&b>=0&&b<q&&!book[a][b])
        return 1;
    return 0;
}
void dfs(int e1x,int e1y,int k)
{
    a[k]=e1y+'A';
    b[k]=e1x+1+'0';
    if(k==p*q)
    {
            flag=1;
            for(int i=1; i<=k; i++)
                printf("%c%c",a[i],b[i]);
            printf("\n");
      return;
    }
    book[e1x][e1y]=1;
    for(int i=0; i<8; i++)
    {
        int tx=e1x+ne[i][0];
        int ty=e1y+ne[i][1];
        if(jud(tx,ty)&&!flag)
        {
            book[tx][ty]=1;
            dfs(tx,ty,k+1);
            book[tx][ty]=0;
        }
    }
}
int main()
{
    int t,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&q);
        mem(book,0);
        flag=0;
        printf("Scenario #%d:\n",ca++);
        dfs(0,0,1);
       if(flag==0)
        printf("impossible\n");
        if(t)
        printf("\n");
    }
    return 0;
}
wa代码:
#include<queue>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int ne[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
char a[1010];
int p,q,flag=0,sum;
int book[88][88];
bool jud(int a,int b)
{
    if(a>0&&a<=p&&b>0&&b<=q&&!book[a][b])
        return 1;
    return 0;
}
void dfs(int e1x,int e1y,int k)
{
    a[sum++]=e1y+'A'-1;
    a[sum++]=e1x+'0';
    if(k==p*q)
    {
        flag=1;
        return;
    }
    for(int i=0; i<8; i++)
    {
        int tx=e1x+ne[i][0];
        int ty=e1y+ne[i][1];
        if(jud(tx,ty)&&!flag)
        {
            book[tx][ty]=1;
            dfs(tx,ty,k+1);
            book[tx][ty]=0;
        }
    }
}
int main()
{
    int t,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&q);
        mem(book,0);
        mem(a,'#');
        flag=0;
        sum=0;
        book[1][1]=1;
        printf("Scenario #%d:\n",ca++);
        dfs(1,1,1);
        if(flag==0)
            printf("impossible\n");
        else
        {
            for(int i=0; i<sum; i++)
                printf("%c",a[i]);
            printf("\n");
        }

        if(t)
            printf("\n");
    }
    return 0;
}


   

猜你喜欢

转载自blog.csdn.net/team39/article/details/80139001
今日推荐