G - Power Strings (KMP——最小循环节)

G - Power Strings

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:

             求最小循环节个数

注:

      1)当输入" . " (最后一个样例),结束。

       2)数据范围1~1000000

       3)当S长度不能除尽循环节时,输出1;

代码:

#include<map>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define Mlm 1000005    //数据范围1~1000000
int ne[Mlm];
char mo[Mlm];
int lm,lt;
void nex()
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<lm)
    {
        while(j!=-1&&mo[j]!=mo[i])
            j=ne[j];
        ne[++i]=++j;
    }
}
int main()
{

    while(~scanf("%s",mo))
    {
        if(mo[0]=='.')
            break;
        memset(ne,0,sizeof(ne));
        lm=strlen(mo);
        nex();
        int Xun=lm-ne[lm];    //求最小循环节

        if(lm%(Xun)!=0)     //当S长度不能除尽循环节时,输出1;
            printf("1\n");
        else
            printf("%d\n",lm/Xun);
    }
return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81082476
今日推荐