杭电1496

Equations

Time Limit: 6000/3000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

思路:

(1)将方程式写成a * x1 * x1 + b * x2 * x2 = - (c * x3 * x3 + d * x4 * x4)的形式;
(2)使用hash,但是不知道为什么,数组命名为hash就会编译错误,所以命名为vis;
(3)50 * 100 *100 + 50 *100 *100=1000000,所以hash数组至少要2000000;
(4)a * x1 * x1 + b * x2 * x2最小为-1000000,所以数组要加上1000000的偏移量,以保证数组下标最小为0,而不是负数;
(5)因为正负号不同不影响平方的效果,所以只枚举正数,最后乘以2的4次方(16),表示正负不同的组合。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define maxn 2000008 //100*100*50*4=2000000
int vis[maxn];

int main()
{
    int a,b,c,d;
    while(cin>>a>>b>>c>>d) 
    {
        if(a>0&&b>0&&c>0&&d>0 || a<0&&b<0&&c<0&&d<0)
        {
            cout<<0<<endl;
        }
        else
        {
            memset(vis,0,sizeof(vis));
            //偏移量为1000000,保证数组下标不为负数
            for(int x1=1;x1<=100;x1++)
            {
                for(int x2=1;x2<=100;x2++)
                {
                    //将数组下标为a*x1*x1+b*x2*x2的值置为1
                    vis[1000000+a*x1*x1+b*x2*x2]++;
                }
            }
            int count=0;
            //偏移量为1000000
            for(int x3=1;x3<=100;x3++)
            {
                for(int x4=1;x4<=100;x4++)
                {
                    /*下标为c*x3*x3+d*x4*x4的值为1则是解,为0则不是解
                      值为1的个数即为解的总个数,由于0不影响结果
                      所以可直接用count+=vis[1000000-(c*x3*x3+d*x4*x4)]
                    */
                    count+=vis[1000000-(c*x3*x3+d*x4*x4)];
                }
            }
            cout<<count*16<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Albert_Bolt/article/details/81099023