暑期集训1:C++&STL 练习题E:POJ-2431

2018学校暑期集训第一天——C++与STL

练习题E ——  POJ - 2431

E - 二律背反的对偶

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 
* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 
* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

解题方向:贪心+优先级队列

解题思路:如果每个加油站加的油均为相同值,则可以按照贪心直接处理。但由于每个加油站能加的油量不等,而且为了使加油次数最小,显然就要选择加油量最大的加油站先加。因此需要使用优先权队列,即每到一个加油站,将其入队列,补油时直接从队列里找,队列为空时说明不可达(需要排序因为距离不定)

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#define MAXN 10005
using namespace std;

struct Node {
    int fuel, dis;
};

bool comp(const Node &lhs, const Node &rhs) {
    return lhs.dis < rhs.dis;
}

int main(int argc, char *argv[]) {
    int n, p, l;
    Node stat[MAXN];
    priority_queue<int> que;

    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d%d", &stat[i].dis, &stat[i].fuel);
    }
    scanf("%d%d", &l, &p);
    for (int i = 0; i < n; i++) {
        stat[i].dis = l - stat[i].dis;
    }
    stat[n].dis = l;
    sort(stat, stat + n, comp);

    int pos = 0, ans = 0, tank = p;
    for (int i = 0; i <= n; i++) {
        int d = stat[i].dis - pos;
        while (tank - d < 0) {
            if (que.empty()) {
                cout << "-1";
                return 0;
            }
            tank += que.top();
            que.pop();
            ans++;
        }
        tank -= d;
        que.push(stat[i].fuel);
        pos = stat[i].dis;
    }

    cout << ans;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/mofadiyu/article/details/81072424
今日推荐