HDU - 5127 Dogs' Candies

Dogs' Candies

Time Limit: 30000/30000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3326    Accepted Submission(s): 814


Problem Description
Far far away, there live a lot of dogs in the forest. Unlike other dogs, those dogs love candies much more than bones.

Every candy has two attributes: the sweetness degree p and the sourness degree q. Different dogs like different candies. A dog also has two attributes: the fondness degree for sweetness x and the fondness degree for sourness y. So the deliciousness degree of a candy for a dog is defined as p×x + q×y.

The dog king has a huge candy box. At first, the box is empty. The king can add candies to the box or take some candies from the box and eat them. There are always some dogs who want to know which candies in the box are the most delicious for them. Please help the king to answer their questions.
 

Input
The input consists of at most 10 test cases. For each test case, the first line contains an integer n indicating that there are n candy box operations(1 <= n <= 50000).

The following n lines describe the n operations.

Each operation contains three integers t, x and y( 0 <= |x|, |y| <= 109). The first integer t may be -1, 0, or 1.

If t equals -1, it means that a candy in the box with sweetness degree x and sourness degree y is eaten by the dog king.

If t equals 1, it means that a candy with sweetness degree x and sourness degree y is added to the candy box.

If t equals 0, it means that a dog with sweetness fondness degree x and sourness fondness degree y wants to know the maximal deliciousness degree of the candies in the box for him. 

It is guaranteed that every candy is unique in the box. 

The input ends by n = 0.
 

Output
For each operation in which t equals to 0, you should print the maximal deliciousness degree of the best candy for the dog.
 

Sample Input
 
  
6 1 2 1 1 1 2 1 1 1 0 2 1 -1 2 1 0 2 1 0
 

Sample Output
 
  
5 4

#include <iostream>
#include <string>
#include <vector>
#define ll long long
using namespace std;
struct candy
{
	ll x;
	ll y;
	ll num;//有没有  
}c[50005];
//-1 取 1 放 0 判断
int main()
{
	int t;
	while(cin>>t,t)
	{
		int index=0;
		while(t--) 
		{
			ll n,x,y;
			cin>>n;
			if(n==1)//放 
			{
				cin>>c[index].x>>c[index].y;
				c[index].num=1;
				index++;
			}
		
			else if(n==-1)//取  
			{
				cin>>x>>y;
				for(int j=0;j<index;j++)
				{
					if(c[j].x==x&&c[j].y==y&&c[j].num)
					{		
						c[j].num=0;	
						break;
					}
				}
			}
			else if(n==0)//判断 
			{
				cin>>x>>y;
				ll sum=-99999;
				for(int j=0;j<index;j++)
				{
					if(c[j].num)
					{
						ll l=c[j].x*x+c[j].y*y;
						if(l>sum)
						{
						//	cout<<c[j].x<<" "<<c[j].y<<endl;
							sum=l;	
						}
					}
					
					
				}
				cout<<sum<<endl;
			}
		}	
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/80994463