FZU 1046 Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
InputThe input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
OutputFor each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO

YES

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int n,m,t;
int si,sj,di,dj;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
char map[9][9];
int flag;
void dfs(int si,int sj,int time)
{
	if(si>n||si<1||sj>m||sj<1)return;
	if(time==t&&si==di&&sj==dj)flag=1;
	if(flag)return ;
	if(((si+sj)%2==(di+dj)%2)&&((t-time)%2==1))return;
	if(((si+sj)%2!=(di+dj)%2)&&((t-time)%2==0))return;
	for(int i=0;i<4;i++)
	{
		if(map[si+dir[i][0]][sj+dir[i][1]]!='X')
		{
			map[si+dir[i][0]][sj+dir[i][1]]='X';
			dfs(si+dir[i][0],sj+dir[i][1],time+1);
			map[si+dir[i][0]][sj+dir[i][1]]='.';
		}
	}
	return;
}
int main()
{
	while(cin>>n>>m>>t)
	{
		if(n==0&&m==0&&t==0)break;
		int wall=0;//判断墙的数目;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='S')
				{
					si=i;
					sj=j;
				}
				if(map[i][j]=='D')
				{
					di=i;
					dj=j;
				}
				if(map[i][j]=='X')wall++;
			}
		}
			map[si][sj]='X';
			flag=0;
			dfs(si,sj,0);
			if(flag)
			cout<<"YES"<<endl; 
             else 
	        cout<<"NO"<<endl; 
		} 
		return 0;
}


猜你喜欢

转载自blog.csdn.net/nihaopeng521/article/details/76176239
今日推荐